Bug Gambas 3.3.2

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug Gambas 3.3.2

Emmanuel DOUSSELIN
Bonjour,

J'utilise la version de Gambas3 dans les depot de Archinux . C'est la version 3.3.2. Depuis la dernière maj de Gambas j'ai cette erreur :

This application has raised an unexpected
error and must abort.

[11] Unknown symbol 'Current' in class '.Editor.Line'.
FEditor.Editors_Cursor.451

Merci d'avance
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Benoît Minisini
Le 10/10/2012 14:41, Emmanuel DOUSSELIN a écrit :

>
> Bonjour,
>
> J'utilise la version de Gambas3 dans les depot de Archinux . C'est la
> version 3.3.2. Depuis la dernière maj de Gambas j'ai cette erreur :
>
> This application has raised an unexpected
> error and must abort.
>
> [11] Unknown symbol 'Current' in class '.Editor.Line'.
> FEditor.Editors_Cursor.451
>
> Merci d'avance
>

Il n'y a pas de ligne 451 et de symbole "Current" dans le code source de
la 3.3.2 à l'endroit indiqué. C'est soit un bug dans ton système, soit
un bug dans les packages de ArchLinux. Essaie de désinstaller et de
supprimer tout ce qui a trait à Gambas 3 et de réinstaller.

--
Benoît Minisini

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Emmanuel DOUSSELIN
Benoît Minisini wrote
Il n'y a pas de ligne 451 et de symbole "Current" dans le code source de
la 3.3.2 à l'endroit indiqué. C'est soit un bug dans ton système, soit
un bug dans les packages de ArchLinux. Essaie de désinstaller et de
supprimer tout ce qui a trait à Gambas 3 et de réinstaller.

--
Benoît Minisini

Une suppression puis réinstallation de Gambas3 ne règle pas le problème.
J’espère que Laurent passera par là assez vite.
Sinon je vais peut être désinstaller la version paquets et remettre la Svn pour voire si mon système est en cause mais bon, on s'habitue au confort des dépôts ;)

Manu
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Benoît Minisini
In reply to this post by Benoît Minisini
Le 10/10/2012 17:59, Emmanuel DOUSSELIN a écrit :
>
>
>
>
> Il n'y a pas de ligne 451 et de symbole "Current" dans le code source de
> la 3.3.2 à l'endroit indiqué. C'est soit un bug dans ton système, soit
> un bug dans les packages de ArchLinux. Essaie de désinstaller et de
> supprimer tout ce qui a trait à Gambas 3 et de réinstaller.
>

De toute façon, je vais bientôt générer une 3.3.3...

--
Benoît Minisini

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Fabien Bodard-4

La svn tourne bien sûr arch

Le 10 oct. 2012 18:01, "Benoît Minisini" <[hidden email]> a écrit :
Le 10/10/2012 17:59, Emmanuel DOUSSELIN a écrit :
>
>
>
>
> Il n'y a pas de ligne 451 et de symbole "Current" dans le code source de
> la 3.3.2 à l'endroit indiqué. C'est soit un bug dans ton système, soit
> un bug dans les packages de ArchLinux. Essaie de désinstaller et de
> supprimer tout ce qui a trait à Gambas 3 et de réinstaller.
>

De toute façon, je vais bientôt générer une 3.3.3...

--
Benoît Minisini

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Laurent Carlier-2
In reply to this post by Benoît Minisini
Le mercredi 10 octobre 2012 08:59:21 Emmanuel DOUSSELIN a écrit :
> Une suppression puis réinstallation de Gambas3 ne règle pas le problème.
> J’espère que Laurent passera par là assez vite.
> Sinon je vais peut être désinstaller la version paquets et remettre la Svn
> pour voire si mon système est en cause mais bon, on s'habitue au confort des
> dépôts

Y a t-il une procédure pour reproduire ce bug ? Sinon, il y a la version 3.3.3
dans les dépots testing.

++

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr

signature.asc (501 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Emmanuel DOUSSELIN

Laurent Carlier-2 wrote
Y a t-il une procédure pour reproduire ce bug ? Sinon, il y a la version 3.3.3
dans les dépots testing.
Ca ce produit quand je reprends un de mes projet (qui marchais bien avant...). Dés que j'ouvre le projet, j'ai ce message et quand je clique sur ok de la boite de message, je suis éjecté de gambas.

Sur d'autres projets, je n'ai pas de pb. J'essaie de trouver un point commun aux projets qui posent pb...
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Emmanuel DOUSSELIN
In reply to this post by Laurent Carlier-2
je viens de faire la maj vers la 3.3.3 et le problème demeure

...
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Emmanuel DOUSSELIN
In reply to this post by Laurent Carlier-2
Bonjour,


Une installation toute fraîche sur un "nouvel" ordi de Arch avec Gambas 3.3.3 règle le problème. Mais il demeure sur mon ordi. A part une re-installe de Arch, je vois pas trop de solution ou me résoudre à la svn...
Reply | Threaded
Open this post in threaded view
|

Re: Bug Gambas 3.3.2

Emmanuel DOUSSELIN
In reply to this post by Emmanuel DOUSSELIN

Emmanuel DOUSSELIN wrote
J'essaie de trouver un point commun aux projets qui posent pb...
Bonjour,

Le point commun aux projets qui me générent cette erreur, est cette ligne qui apparait en console linux lorsque je charge le projet a partir de gambas lui même lancé à partir d'une console linux. La ligne est la suivante :

CComponent.InitComponent.294: Unable to read component file: gb.data.component
En fait j'ai tous cela aussi :

[manu@bureau ~]$ gambas3
gb.qt4: warning: unable to load Qt translation: fr_FR.utf8
CComponent.InitComponent.294: Unable to read component file: gb.data.component
gb.qt4.ext: Highlight.Alternate is deprecated. Do not use it anymore
gb.qt4.ext: Highlight.Alternate is deprecated. Do not use it anymore
gb.qt4.ext: Highlight.Alternate is deprecated. Do not use it anymore
gb.qt4.ext: Highlight.Alternate is deprecated. Do not use it anymore
gb.qt4.ext: Highlight.Alternate is deprecated. Do not use it anymore
FEditor.Editors_Cursor.451: #11: Unknown symbol 'Current' in class '.Editor.Line
Pour moi c'est du chinois !!!