Errors compiling on Ubuntu 17.04 zesty

classic Classic list List threaded Threaded
25 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Errors compiling on Ubuntu 17.04 zesty

Gianluigi
A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
Gambas gets error of Impossible to find package for libsage-dev and
llvm-3.5-dev.
I searched on https://packages.ubuntu.com/ and concerning llvm the oldest
library available in zesty is 3.7, while concerning libsage I get nothing,
but looking in descriptions for Supports OpenGL in SDL applications, I
seemed to understand that gambas3-gb-opengl-sge should replace it.
How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no 3.5?
Can you help me?

Regards

Gianluigi
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
Le 20/06/2017 à 17:38, Gianluigi a écrit :

> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
> Gambas gets error of Impossible to find package for libsage-dev and
> llvm-3.5-dev.
> I searched on https://packages.ubuntu.com/ and concerning llvm the oldest
> library available in zesty is 3.7, while concerning libsage I get nothing,
> but looking in descriptions for Supports OpenGL in SDL applications, I
> seemed to understand that gambas3-gb-opengl-sge should replace it.
> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no 3.5?
> Can you help me?
>
> Regards
>
> Gianluigi

You cannot compile gb.jit anymore on recent Ubuntu systems, as they
removed llvm 3.5. So just let it be disabled.

And don't specify libsage-dev, it should work without. If not, just tell me.

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by Gianluigi
I had immediately answered to the mail of Benoit but here [0] not appear,
what am I doing wrong?

Regards
Gianluigi

[0]
http://gambas.8142.n7.nabble.com/Errors-compiling-on-Ubuntu-17-04-zesty-td59433.html

2017-06-20 17:38 GMT+02:00 Gianluigi <[hidden email]>:

> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
> Gambas gets error of Impossible to find package for libsage-dev and
> llvm-3.5-dev.
> I searched on https://packages.ubuntu.com/ and concerning llvm the oldest
> library available in zesty is 3.7, while concerning libsage I get nothing,
> but looking in descriptions for Supports OpenGL in SDL applications, I
> seemed to understand that gambas3-gb-opengl-sge should replace it.
> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no 3.5?
> Can you help me?
>
> Regards
>
> Gianluigi
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

PICCORO McKAY Lenz
In reply to this post by gambas-user mailing list
no jit on recents systems due changes!

its very frustrating the constans changes on the software world..

every day we are more like M$!

why update and changes if are working? *ah of course, securyity the always
working excuse!*



Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

2017-06-20 11:13 GMT-04:30 Benoît Minisini via Gambas-user <
[hidden email]>:

> Le 20/06/2017 à 17:38, Gianluigi a écrit :
>
>> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
>> Gambas gets error of Impossible to find package for libsage-dev and
>> llvm-3.5-dev.
>> I searched on https://packages.ubuntu.com/ and concerning llvm the oldest
>> library available in zesty is 3.7, while concerning libsage I get nothing,
>> but looking in descriptions for Supports OpenGL in SDL applications, I
>> seemed to understand that gambas3-gb-opengl-sge should replace it.
>> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no
>> 3.5?
>> Can you help me?
>>
>> Regards
>>
>> Gianluigi
>>
>
> You cannot compile gb.jit anymore on recent Ubuntu systems, as they
> removed llvm 3.5. So just let it be disabled.
>
> And don't specify libsage-dev, it should work without. If not, just tell
> me.
>
> Regards,
>
> --
> Benoît Minisini
>
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by Gianluigi
After the configuration he gets this result:
||
|| THESE COMPONENTS ARE DISABLED:
|| - gb.jit
|| - gb.openssl
||
expected for gb.jit but not for gb.openssl.
Gambas installs but he continues to be unable to use it either by clicking
on the icon or with the gambas3 command from the terminal.
Any suggestions?
At follow the final output of the installation

Regards
Gianluigi

Installing the components...
Compiling gb.eval.highlight...
OK
Installing gb.eval.highlight...
Compiling gb.args...
OK
Installing gb.args...
Compiling gb.settings...
OK
Installing gb.settings...
Compiling gb.gui.base...
OK
Installing gb.gui.base...
Compiling gb.form...
OK
Installing gb.form...
Compiling gb.form.stock...
OK
Installing gb.form.stock...
Compiling gb.form.dialog...
OK
Installing gb.form.dialog...
Compiling gb.form.mdi...
OK
Installing gb.form.mdi...
Compiling gb.db.form...
OK
Installing gb.db.form...
Compiling gb.desktop...
OK
Installing gb.desktop...
Compiling gb.web...
OK
Installing gb.web...
Compiling gb.report...
OK
Installing gb.report...
Compiling gb.report2...
OK
Installing gb.report2...
Compiling gb.chart...
OK
Installing gb.chart...
Compiling gb.mysql...
OK
Installing gb.mysql...
Compiling gb.net.smtp...
OK
Installing gb.net.smtp...
Compiling gb.net.pop3...
OK
Installing gb.net.pop3...
Compiling gb.memcached...
OK
Installing gb.memcached...
Compiling gb.map...
OK
Installing gb.map...
Compiling gb.logging...
OK
Installing gb.logging...
Compiling gb.markdown...
OK
Installing gb.markdown...
Compiling gb.media.form...
OK
Installing gb.media.form...
Compiling gb.scanner...
OK
Installing gb.scanner...
Compiling gb.util...
OK
Installing gb.util...
Compiling gb.util.web...
OK
Installing gb.util.web...
Compiling gb.form.editor...
OK
Installing gb.form.editor...
Compiling gb.dbus.trayicon...
OK
Installing gb.dbus.trayicon...
Compiling gb.web.form...
OK
Installing gb.web.form...
Compiling gb.form.terminal...
OK
Installing gb.form.terminal...
Compiling gb.term.form...
OK
Installing gb.term.form...
Compiling gb.web.feed...
OK
Installing gb.web.feed...
make[2]: Nessuna operazione da eseguire per "install-data-am".
make[2]: uscita dalla directory "/home/luca/trunk/comp"
make[1]: uscita dalla directory "/home/luca/trunk/comp"
Making install in app
make[1]: ingresso nella directory "/home/luca/trunk/app"
make[2]: ingresso nella directory "/home/luca/trunk/app"
Installing the development environment...
Compiling gambas3...
OK
Installing gambas3...
Compiling gbs3...
OK
Installing gbs3...
Installing the scripter...
Registering Gambas script mimetype
Registering Gambas server page mimetype
Installing the Gambas appdata file
Installing the Gambas template projects
/usr/bin/install -c -d /usr/share/gambas3/template;
cp -R ./template/* /usr/share/gambas3/template;
make[2]: Nessuna operazione da eseguire per "install-data-am".
make[2]: uscita dalla directory "/home/luca/trunk/app"
make[1]: uscita dalla directory "/home/luca/trunk/app"
Making install in .
make[1]: ingresso nella directory "/home/luca/trunk"
make[2]: ingresso nella directory "/home/luca/trunk"
make[2]: Nessuna operazione da eseguire per "install-data-am".
make[2]: uscita dalla directory "/home/luca/trunk"
make[1]: uscita dalla directory "/home/luca/trunk"

2017-06-20 22:43 GMT+02:00 Gianluigi <[hidden email]>:

> I had immediately answered to the mail of Benoit but here [0] not appear,
> what am I doing wrong?
>
> Regards
> Gianluigi
>
> [0] http://gambas.8142.n7.nabble.com/Errors-compiling-on-
> Ubuntu-17-04-zesty-td59433.html
>
> 2017-06-20 17:38 GMT+02:00 Gianluigi <[hidden email]>:
>
>> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
>> Gambas gets error of Impossible to find package for libsage-dev and
>> llvm-3.5-dev.
>> I searched on https://packages.ubuntu.com/ and concerning llvm the
>> oldest library available in zesty is 3.7, while concerning libsage I get
>> nothing, but looking in descriptions for Supports OpenGL in SDL
>> applications, I seemed to understand that gambas3-gb-opengl-sge should
>> replace it.
>> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no
>> 3.5?
>> Can you help me?
>>
>> Regards
>>
>> Gianluigi
>>
>
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
Le 21/06/2017 à 14:41, Gianluigi a écrit :

> After the configuration he gets this result:
> ||
> || THESE COMPONENTS ARE DISABLED:
> || - gb.jit
> || - gb.openssl
> ||
> expected for gb.jit but not for gb.openssl.
> Gambas installs but he continues to be unable to use it either by clicking
> on the icon or with the gambas3 command from the terminal.
> Any suggestions?
> At follow the final output of the installation
>
> Regards
> Gianluigi
>
> Installing the components...
> Compiling gb.eval.highlight...
> OK
> Installing gb.eval.highlight...
> Compiling gb.args...
> OK
> Installing gb.args...
> Compiling gb.settings...
> OK
> Installing gb.settings...
> Compiling gb.gui.base...
> OK
> Installing gb.gui.base...
> Compiling gb.form...
> OK
> Installing gb.form...
> Compiling gb.form.stock...
> OK
> Installing gb.form.stock...
> Compiling gb.form.dialog...
> OK
> Installing gb.form.dialog...
> Compiling gb.form.mdi...
> OK
> Installing gb.form.mdi...
> Compiling gb.db.form...
> OK
> Installing gb.db.form...
> Compiling gb.desktop...
> OK
> Installing gb.desktop...
> Compiling gb.web...
> OK
> Installing gb.web...
> Compiling gb.report...
> OK
> Installing gb.report...
> Compiling gb.report2...
> OK
> Installing gb.report2...
> Compiling gb.chart...
> OK
> Installing gb.chart...
> Compiling gb.mysql...
> OK
> Installing gb.mysql...
> Compiling gb.net.smtp...
> OK
> Installing gb.net.smtp...
> Compiling gb.net.pop3...
> OK
> Installing gb.net.pop3...
> Compiling gb.memcached...
> OK
> Installing gb.memcached...
> Compiling gb.map...
> OK
> Installing gb.map...
> Compiling gb.logging...
> OK
> Installing gb.logging...
> Compiling gb.markdown...
> OK
> Installing gb.markdown...
> Compiling gb.media.form...
> OK
> Installing gb.media.form...
> Compiling gb.scanner...
> OK
> Installing gb.scanner...
> Compiling gb.util...
> OK
> Installing gb.util...
> Compiling gb.util.web...
> OK
> Installing gb.util.web...
> Compiling gb.form.editor...
> OK
> Installing gb.form.editor...
> Compiling gb.dbus.trayicon...
> OK
> Installing gb.dbus.trayicon...
> Compiling gb.web.form...
> OK
> Installing gb.web.form...
> Compiling gb.form.terminal...
> OK
> Installing gb.form.terminal...
> Compiling gb.term.form...
> OK
> Installing gb.term.form...
> Compiling gb.web.feed...
> OK
> Installing gb.web.feed...
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk/comp"
> make[1]: uscita dalla directory "/home/luca/trunk/comp"
> Making install in app
> make[1]: ingresso nella directory "/home/luca/trunk/app"
> make[2]: ingresso nella directory "/home/luca/trunk/app"
> Installing the development environment...
> Compiling gambas3...
> OK
> Installing gambas3...
> Compiling gbs3...
> OK
> Installing gbs3...
> Installing the scripter...
> Registering Gambas script mimetype
> Registering Gambas server page mimetype
> Installing the Gambas appdata file
> Installing the Gambas template projects
> /usr/bin/install -c -d /usr/share/gambas3/template;
> cp -R ./template/* /usr/share/gambas3/template;
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk/app"
> make[1]: uscita dalla directory "/home/luca/trunk/app"
> Making install in .
> make[1]: ingresso nella directory "/home/luca/trunk"
> make[2]: ingresso nella directory "/home/luca/trunk"
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk"
> make[1]: uscita dalla directory "/home/luca/trunk"
>
> 2017-06-20 22:43 GMT+02:00 Gianluigi <[hidden email]>:
>
>> I had immediately answered to the mail of Benoit but here [0] not appear,
>> what am I doing wrong?
>>
>> Regards
>> Gianluigi
>>
>> [0] http://gambas.8142.n7.nabble.com/Errors-compiling-on-
>> Ubuntu-17-04-zesty-td59433.html
>>
>> 2017-06-20 17:38 GMT+02:00 Gianluigi <[hidden email]>:
>>
>>> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
>>> Gambas gets error of Impossible to find package for libsage-dev and
>>> llvm-3.5-dev.
>>> I searched on https://packages.ubuntu.com/ and concerning llvm the
>>> oldest library available in zesty is 3.7, while concerning libsage I get
>>> nothing, but looking in descriptions for Supports OpenGL in SDL
>>> applications, I seemed to understand that gambas3-gb-opengl-sge should
>>> replace it.
>>> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no
>>> 3.5?
>>> Can you help me?
>>>
>>> Regards
>>>
>>> Gianluigi
>>>
>>
>>

You must uninstall all previous installations of Gambas 3 on your system
before compiling and installing from sources.

You must provide the entire output of configuration, compilation &
installation process, so that we can see what happens.

Did you install the development packages specified on
http://gambaswiki.org/wiki/install/ubuntu#t7 ?

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by Gianluigi
Now the terminal has given this error;

Settings.WriteWindow.393: #20: Bad argument
Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
FMain.Form_Open.78 Project.Main.366

Regards
Gianluigi

2017-06-21 14:41 GMT+02:00 Gianluigi <[hidden email]>:

> After the configuration he gets this result:
> ||
> || THESE COMPONENTS ARE DISABLED:
> || - gb.jit
> || - gb.openssl
> ||
> expected for gb.jit but not for gb.openssl.
> Gambas installs but he continues to be unable to use it either by clicking
> on the icon or with the gambas3 command from the terminal.
> Any suggestions?
> At follow the final output of the installation
>
> Regards
> Gianluigi
>
> Installing the components...
> Compiling gb.eval.highlight...
> OK
> Installing gb.eval.highlight...
> Compiling gb.args...
> OK
> Installing gb.args...
> Compiling gb.settings...
> OK
> Installing gb.settings...
> Compiling gb.gui.base...
> OK
> Installing gb.gui.base...
> Compiling gb.form...
> OK
> Installing gb.form...
> Compiling gb.form.stock...
> OK
> Installing gb.form.stock...
> Compiling gb.form.dialog...
> OK
> Installing gb.form.dialog...
> Compiling gb.form.mdi...
> OK
> Installing gb.form.mdi...
> Compiling gb.db.form...
> OK
> Installing gb.db.form...
> Compiling gb.desktop...
> OK
> Installing gb.desktop...
> Compiling gb.web...
> OK
> Installing gb.web...
> Compiling gb.report...
> OK
> Installing gb.report...
> Compiling gb.report2...
> OK
> Installing gb.report2...
> Compiling gb.chart...
> OK
> Installing gb.chart...
> Compiling gb.mysql...
> OK
> Installing gb.mysql...
> Compiling gb.net.smtp...
> OK
> Installing gb.net.smtp...
> Compiling gb.net.pop3...
> OK
> Installing gb.net.pop3...
> Compiling gb.memcached...
> OK
> Installing gb.memcached...
> Compiling gb.map...
> OK
> Installing gb.map...
> Compiling gb.logging...
> OK
> Installing gb.logging...
> Compiling gb.markdown...
> OK
> Installing gb.markdown...
> Compiling gb.media.form...
> OK
> Installing gb.media.form...
> Compiling gb.scanner...
> OK
> Installing gb.scanner...
> Compiling gb.util...
> OK
> Installing gb.util...
> Compiling gb.util.web...
> OK
> Installing gb.util.web...
> Compiling gb.form.editor...
> OK
> Installing gb.form.editor...
> Compiling gb.dbus.trayicon...
> OK
> Installing gb.dbus.trayicon...
> Compiling gb.web.form...
> OK
> Installing gb.web.form...
> Compiling gb.form.terminal...
> OK
> Installing gb.form.terminal...
> Compiling gb.term.form...
> OK
> Installing gb.term.form...
> Compiling gb.web.feed...
> OK
> Installing gb.web.feed...
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk/comp"
> make[1]: uscita dalla directory "/home/luca/trunk/comp"
> Making install in app
> make[1]: ingresso nella directory "/home/luca/trunk/app"
> make[2]: ingresso nella directory "/home/luca/trunk/app"
> Installing the development environment...
> Compiling gambas3...
> OK
> Installing gambas3...
> Compiling gbs3...
> OK
> Installing gbs3...
> Installing the scripter...
> Registering Gambas script mimetype
> Registering Gambas server page mimetype
> Installing the Gambas appdata file
> Installing the Gambas template projects
> /usr/bin/install -c -d /usr/share/gambas3/template;
> cp -R ./template/* /usr/share/gambas3/template;
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk/app"
> make[1]: uscita dalla directory "/home/luca/trunk/app"
> Making install in .
> make[1]: ingresso nella directory "/home/luca/trunk"
> make[2]: ingresso nella directory "/home/luca/trunk"
> make[2]: Nessuna operazione da eseguire per "install-data-am".
> make[2]: uscita dalla directory "/home/luca/trunk"
> make[1]: uscita dalla directory "/home/luca/trunk"
>
> 2017-06-20 22:43 GMT+02:00 Gianluigi <[hidden email]>:
>
>> I had immediately answered to the mail of Benoit but here [0] not appear,
>> what am I doing wrong?
>>
>> Regards
>> Gianluigi
>>
>> [0] http://gambas.8142.n7.nabble.com/Errors-compiling-on-Ubuntu-
>> 17-04-zesty-td59433.html
>>
>> 2017-06-20 17:38 GMT+02:00 Gianluigi <[hidden email]>:
>>
>>> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
>>> Gambas gets error of Impossible to find package for libsage-dev and
>>> llvm-3.5-dev.
>>> I searched on https://packages.ubuntu.com/ and concerning llvm the
>>> oldest library available in zesty is 3.7, while concerning libsage I get
>>> nothing, but looking in descriptions for Supports OpenGL in SDL
>>> applications, I seemed to understand that gambas3-gb-opengl-sge should
>>> replace it.
>>> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no
>>> 3.5?
>>> Can you help me?
>>>
>>> Regards
>>>
>>> Gianluigi
>>>
>>
>>
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by gambas-user mailing list
He should have followed this path I suggested:

sudo rm -f /usr/local/bin/gbx3 /usr/local/bin/gbc3 /usr/local/bin/gba3
/usr/local/bin/gbi3 /usr/local/bin/gbs3
sudo rm -rf /usr/local/lib/gambas3
sudo rm -rf /usr/local/share/gambas3
sudo rm -f /usr/local/bin/gambas3
sudo rm -f /usr/local/bin/gambas3.gambas

sudo rm -f /usr/bin/gbx3 /usr/bin/gbc3 /usr/bin/gba3 /usr/bin/gbi3
/usr/local/bin/gbs3
sudo rm -rf /usr/lib/gambas3
sudo rm -rf /usr/share/gambas3
sudo rm -f /usr/bin/gambas3
sudo rm -f /usr/bin/gambas3.gambas

sudo apt update

sudo apt install build-essential g++ automake autoconf libtool libbz2-dev
libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-9.6
libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev
libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev
libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev
librsvg2-dev libpoppler-dev libpoppler-glib-dev libpoppler-private-dev
libasound2-dev libesd0-dev libdirectfb-dev libxtst-dev libffi-dev
libqt4-dev libqtwebkit-dev libqt4-opengl-dev libglew1.6-dev libimlib2-dev
libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev
linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev
libcairo2-dev libgsl0-dev libncurses5-dev libgmime-2.6-dev libalure-dev
libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev
libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev libqt5svg5-dev
libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev

sudo apt install subversion

svn checkout svn://svn.code.sf.net/p/gambas/code/gambas/trunk

cd trunk

( ./reconf-all && ./configure -C ) > ~/Scrivania/R_conf-Trunk.log 2>&1

( make && sudo make install ) > ~/Scrivania/Make_Inst-Trunk.log 2>&1

I attach the two log files
Regards
Gianluigi

2017-06-21 14:47 GMT+02:00 Benoît Minisini <[hidden email]>:

> Le 21/06/2017 à 14:41, Gianluigi a écrit :
>
>> After the configuration he gets this result:
>> ||
>> || THESE COMPONENTS ARE DISABLED:
>> || - gb.jit
>> || - gb.openssl
>> ||
>> expected for gb.jit but not for gb.openssl.
>> Gambas installs but he continues to be unable to use it either by clicking
>> on the icon or with the gambas3 command from the terminal.
>> Any suggestions?
>> At follow the final output of the installation
>>
>> Regards
>> Gianluigi
>>
>> Installing the components...
>> Compiling gb.eval.highlight...
>> OK
>> Installing gb.eval.highlight...
>> Compiling gb.args...
>> OK
>> Installing gb.args...
>> Compiling gb.settings...
>> OK
>> Installing gb.settings...
>> Compiling gb.gui.base...
>> OK
>> Installing gb.gui.base...
>> Compiling gb.form...
>> OK
>> Installing gb.form...
>> Compiling gb.form.stock...
>> OK
>> Installing gb.form.stock...
>> Compiling gb.form.dialog...
>> OK
>> Installing gb.form.dialog...
>> Compiling gb.form.mdi...
>> OK
>> Installing gb.form.mdi...
>> Compiling gb.db.form...
>> OK
>> Installing gb.db.form...
>> Compiling gb.desktop...
>> OK
>> Installing gb.desktop...
>> Compiling gb.web...
>> OK
>> Installing gb.web...
>> Compiling gb.report...
>> OK
>> Installing gb.report...
>> Compiling gb.report2...
>> OK
>> Installing gb.report2...
>> Compiling gb.chart...
>> OK
>> Installing gb.chart...
>> Compiling gb.mysql...
>> OK
>> Installing gb.mysql...
>> Compiling gb.net.smtp...
>> OK
>> Installing gb.net.smtp...
>> Compiling gb.net.pop3...
>> OK
>> Installing gb.net.pop3...
>> Compiling gb.memcached...
>> OK
>> Installing gb.memcached...
>> Compiling gb.map...
>> OK
>> Installing gb.map...
>> Compiling gb.logging...
>> OK
>> Installing gb.logging...
>> Compiling gb.markdown...
>> OK
>> Installing gb.markdown...
>> Compiling gb.media.form...
>> OK
>> Installing gb.media.form...
>> Compiling gb.scanner...
>> OK
>> Installing gb.scanner...
>> Compiling gb.util...
>> OK
>> Installing gb.util...
>> Compiling gb.util.web...
>> OK
>> Installing gb.util.web...
>> Compiling gb.form.editor...
>> OK
>> Installing gb.form.editor...
>> Compiling gb.dbus.trayicon...
>> OK
>> Installing gb.dbus.trayicon...
>> Compiling gb.web.form...
>> OK
>> Installing gb.web.form...
>> Compiling gb.form.terminal...
>> OK
>> Installing gb.form.terminal...
>> Compiling gb.term.form...
>> OK
>> Installing gb.term.form...
>> Compiling gb.web.feed...
>> OK
>> Installing gb.web.feed...
>> make[2]: Nessuna operazione da eseguire per "install-data-am".
>> make[2]: uscita dalla directory "/home/luca/trunk/comp"
>> make[1]: uscita dalla directory "/home/luca/trunk/comp"
>> Making install in app
>> make[1]: ingresso nella directory "/home/luca/trunk/app"
>> make[2]: ingresso nella directory "/home/luca/trunk/app"
>> Installing the development environment...
>> Compiling gambas3...
>> OK
>> Installing gambas3...
>> Compiling gbs3...
>> OK
>> Installing gbs3...
>> Installing the scripter...
>> Registering Gambas script mimetype
>> Registering Gambas server page mimetype
>> Installing the Gambas appdata file
>> Installing the Gambas template projects
>> /usr/bin/install -c -d /usr/share/gambas3/template;
>> cp -R ./template/* /usr/share/gambas3/template;
>> make[2]: Nessuna operazione da eseguire per "install-data-am".
>> make[2]: uscita dalla directory "/home/luca/trunk/app"
>> make[1]: uscita dalla directory "/home/luca/trunk/app"
>> Making install in .
>> make[1]: ingresso nella directory "/home/luca/trunk"
>> make[2]: ingresso nella directory "/home/luca/trunk"
>> make[2]: Nessuna operazione da eseguire per "install-data-am".
>> make[2]: uscita dalla directory "/home/luca/trunk"
>> make[1]: uscita dalla directory "/home/luca/trunk"
>>
>> 2017-06-20 22:43 GMT+02:00 Gianluigi <[hidden email]>:
>>
>> I had immediately answered to the mail of Benoit but here [0] not appear,
>>> what am I doing wrong?
>>>
>>> Regards
>>> Gianluigi
>>>
>>> [0] http://gambas.8142.n7.nabble.com/Errors-compiling-on-
>>> Ubuntu-17-04-zesty-td59433.html
>>>
>>> 2017-06-20 17:38 GMT+02:00 Gianluigi <[hidden email]>:
>>>
>>> A friend of ours of Italian forum who has Ubuntu 17.04 zesty, compiling
>>>> Gambas gets error of Impossible to find package for libsage-dev and
>>>> llvm-3.5-dev.
>>>> I searched on https://packages.ubuntu.com/ and concerning llvm the
>>>> oldest library available in zesty is 3.7, while concerning libsage I get
>>>> nothing, but looking in descriptions for Supports OpenGL in SDL
>>>> applications, I seemed to understand that gambas3-gb-opengl-sge should
>>>> replace it.
>>>> How to change the LLVM_CONFIG = llvm-config-3.5 command if there is no
>>>> 3.5?
>>>> Can you help me?
>>>>
>>>> Regards
>>>>
>>>> Gianluigi
>>>>
>>>>
>>>
>>>
> You must uninstall all previous installations of Gambas 3 on your system
> before compiling and installing from sources.
>
> You must provide the entire output of configuration, compilation &
> installation process, so that we can see what happens.
>
> Did you install the development packages specified on
> http://gambaswiki.org/wiki/install/ubuntu#t7 ?
>
> --
> Benoît Minisini
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user

Log.tar.gz (46K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
Le 21/06/2017 à 14:56, Gianluigi a écrit :

> He should have followed this path I suggested:
>
> sudo rm -f /usr/local/bin/gbx3 /usr/local/bin/gbc3 /usr/local/bin/gba3
> /usr/local/bin/gbi3 /usr/local/bin/gbs3
> sudo rm -rf /usr/local/lib/gambas3
> sudo rm -rf /usr/local/share/gambas3
> sudo rm -f /usr/local/bin/gambas3
> sudo rm -f /usr/local/bin/gambas3.gambas
>
> sudo rm -f /usr/bin/gbx3 /usr/bin/gbc3 /usr/bin/gba3 /usr/bin/gbi3
> /usr/local/bin/gbs3
> sudo rm -rf /usr/lib/gambas3
> sudo rm -rf /usr/share/gambas3
> sudo rm -f /usr/bin/gambas3
> sudo rm -f /usr/bin/gambas3.gambas
>
> sudo apt update
>
> sudo apt install build-essential g++ automake autoconf libtool
> libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev
> postgresql-server-dev-9.6 libsqlite0-dev libsqlite3-dev libglib2.0-dev
> libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev
> libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev
> libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev
> libpoppler-private-dev libasound2-dev libesd0-dev libdirectfb-dev
> libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev
> libglew1.6-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev
> libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev
> libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev
> libgsl0-dev libncurses5-dev libgmime-2.6-dev libalure-dev libgmp-dev
> libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev
> libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev
> libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev

This is not the development packages specified on the wiki page I told you.

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Tobias Boege-2
In reply to this post by Gianluigi
On Wed, 21 Jun 2017, Gianluigi wrote:

> After the configuration he gets this result:
> ||
> || THESE COMPONENTS ARE DISABLED:
> || - gb.jit
> || - gb.openssl
> ||
> expected for gb.jit but not for gb.openssl.
> Gambas installs but he continues to be unable to use it either by clicking
> on the icon or with the gambas3 command from the terminal.
> Any suggestions?
> At follow the final output of the installation
>

The stuff you give is not relevant to gb.openssl. You only showed the
installation phase of the components written in Gambas, which doesn't
include gb.openssl.

I have a very unpleasant memories [1] about the last time I changed the
configure.ac of gb.openssl. Please make sure first that the openssl
development packages are installed.

Regards,
Tobi

[1] https://sourceforge.net/p/gambas/mailman/gambas-user/thread/BUG984:20160829225438017@.../

--
"There's an old saying: Don't change anything... ever!" -- Mr. Monk

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
In reply to this post by gambas-user mailing list
Le 21/06/2017 à 14:58, Benoît Minisini a écrit :

> Le 21/06/2017 à 14:56, Gianluigi a écrit :
>> He should have followed this path I suggested:
>>
>> sudo rm -f /usr/local/bin/gbx3 /usr/local/bin/gbc3 /usr/local/bin/gba3
>> /usr/local/bin/gbi3 /usr/local/bin/gbs3
>> sudo rm -rf /usr/local/lib/gambas3
>> sudo rm -rf /usr/local/share/gambas3
>> sudo rm -f /usr/local/bin/gambas3
>> sudo rm -f /usr/local/bin/gambas3.gambas
>>
>> sudo rm -f /usr/bin/gbx3 /usr/bin/gbc3 /usr/bin/gba3 /usr/bin/gbi3
>> /usr/local/bin/gbs3
>> sudo rm -rf /usr/lib/gambas3
>> sudo rm -rf /usr/share/gambas3
>> sudo rm -f /usr/bin/gambas3
>> sudo rm -f /usr/bin/gambas3.gambas
>>
>> sudo apt update
>>
>> sudo apt install build-essential g++ automake autoconf libtool
>> libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev
>> postgresql-server-dev-9.6 libsqlite0-dev libsqlite3-dev libglib2.0-dev
>> libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev
>> libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev
>> libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev
>> libpoppler-glib-dev libpoppler-private-dev libasound2-dev libesd0-dev
>> libdirectfb-dev libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev
>> libqt4-opengl-dev libglew1.6-dev libimlib2-dev libv4l-dev
>> libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev
>> linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev
>> libcairo2-dev libgsl0-dev libncurses5-dev libgmime-2.6-dev
>> libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev
>> libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev
>> libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev
>> libqt5x11extras5-dev qtbase5-dev
>
> This is not the development packages specified on the wiki page I told you.
>

It is written:

$ sudo apt-get install build-essential g++ automake autoconf libtool
libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev
postgresql-server-dev-9.3 libsqlite0-dev libsqlite3-dev libglib2.0-dev
libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev
libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev
libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev
libpoppler-private-dev libasound2-dev libesd0-dev libdirectfb-dev
libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev
libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev
libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev
libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev
libgsl0-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev
libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev
libsdl2-image-dev sane-utils libdumb1-dev libssl-dev

For version on /trunk and 3.8 or higher add:

$ sudo apt-get install libqt5opengl5-dev libqt5svg5-dev
libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev

I think just libssl-dev is missing.

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
The libreries you have indicated are the last 5 of the command I suggested,
which is not wrong.
So I just have to let him to add libssl-dev, but I do not think his problem
stems from this, right?
Why he can not run Gambas and get these errors from the terminal?
Settings.WriteWindow.393: #20: Bad argument
Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
FMain.Form_Open.78 Project.Main.366

Regards
Gianluigi

2017-06-21 15:00 GMT+02:00 Benoît Minisini <[hidden email]>:

> Le 21/06/2017 à 14:58, Benoît Minisini a écrit :
>
>> Le 21/06/2017 à 14:56, Gianluigi a écrit :
>>
>>> He should have followed this path I suggested:
>>>
>>> sudo rm -f /usr/local/bin/gbx3 /usr/local/bin/gbc3 /usr/local/bin/gba3
>>> /usr/local/bin/gbi3 /usr/local/bin/gbs3
>>> sudo rm -rf /usr/local/lib/gambas3
>>> sudo rm -rf /usr/local/share/gambas3
>>> sudo rm -f /usr/local/bin/gambas3
>>> sudo rm -f /usr/local/bin/gambas3.gambas
>>>
>>> sudo rm -f /usr/bin/gbx3 /usr/bin/gbc3 /usr/bin/gba3 /usr/bin/gbi3
>>> /usr/local/bin/gbs3
>>> sudo rm -rf /usr/lib/gambas3
>>> sudo rm -rf /usr/share/gambas3
>>> sudo rm -f /usr/bin/gambas3
>>> sudo rm -f /usr/bin/gambas3.gambas
>>>
>>> sudo apt update
>>>
>>> sudo apt install build-essential g++ automake autoconf libtool
>>> libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev
>>> postgresql-server-dev-9.6 libsqlite0-dev libsqlite3-dev libglib2.0-dev
>>> libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev
>>> libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev
>>> libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev
>>> libpoppler-private-dev libasound2-dev libesd0-dev libdirectfb-dev
>>> libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev
>>> libglew1.6-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev
>>> libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev
>>> libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev
>>> libgsl0-dev libncurses5-dev libgmime-2.6-dev libalure-dev libgmp-dev
>>> libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev
>>> libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev libqt5svg5-dev
>>> libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev
>>>
>>
>> This is not the development packages specified on the wiki page I told
>> you.
>>
>>
> It is written:
>
> $ sudo apt-get install build-essential g++ automake autoconf libtool
> libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev
> postgresql-server-dev-9.3 libsqlite0-dev libsqlite3-dev libglib2.0-dev
> libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev
> libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev
> libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev
> libpoppler-private-dev libasound2-dev libesd0-dev libdirectfb-dev
> libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev
> libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev
> libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev
> libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev
> libgsl0-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev
> libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev
> libsdl2-image-dev sane-utils libdumb1-dev libssl-dev
>
> For version on /trunk and 3.8 or higher add:
>
> $ sudo apt-get install libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev
> libqt5x11extras5-dev qtbase5-dev
>
> I think just libssl-dev is missing.
>
> --
> Benoît Minisini
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
Le 21/06/2017 à 15:25, Gianluigi a écrit :

> The libreries you have indicated are the last 5 of the command I
> suggested, which is not wrong.
> So I just have to let him to add libssl-dev, but I do not think his
> problem stems from this, right?
> Why he can not run Gambas and get these errors from the terminal?
> Settings.WriteWindow.393: #20: Bad argument
> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
> FMain.Form_Open.78 Project.Main.366
>
> Regards
> Gianluigi
>

I don't know. I'm working on Kubuntu 17.04, and I have no problem with
compiling Gambas, except the missing llvm 3.5.

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

gambas-user mailing list
Le 21/06/2017 à 15:29, Benoît Minisini a écrit :

> Le 21/06/2017 à 15:25, Gianluigi a écrit :
>> The libreries you have indicated are the last 5 of the command I
>> suggested, which is not wrong.
>> So I just have to let him to add libssl-dev, but I do not think his
>> problem stems from this, right?
>> Why he can not run Gambas and get these errors from the terminal?
>> Settings.WriteWindow.393: #20: Bad argument
>> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
>> FMain.Form_Open.78 Project.Main.366
>>
>> Regards
>> Gianluigi
>>
>
> I don't know. I'm working on Kubuntu 17.04, and I have no problem with
> compiling Gambas, except the missing llvm 3.5.
>

Can you try to recompile the very latest revision? I added some code
that should avoid the specific crash you have.

--
Benoît Minisini

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by Tobias Boege-2
I then attached the log files.
I understand, the library is missing

Regards
Gianluigi

2017-06-21 15:00 GMT+02:00 Tobias Boege <[hidden email]>:

> On Wed, 21 Jun 2017, Gianluigi wrote:
> > After the configuration he gets this result:
> > ||
> > || THESE COMPONENTS ARE DISABLED:
> > || - gb.jit
> > || - gb.openssl
> > ||
> > expected for gb.jit but not for gb.openssl.
> > Gambas installs but he continues to be unable to use it either by
> clicking
> > on the icon or with the gambas3 command from the terminal.
> > Any suggestions?
> > At follow the final output of the installation
> >
>
> The stuff you give is not relevant to gb.openssl. You only showed the
> installation phase of the components written in Gambas, which doesn't
> include gb.openssl.
>
> I have a very unpleasant memories [1] about the last time I changed the
> configure.ac of gb.openssl. Please make sure first that the openssl
> development packages are installed.
>
> Regards,
> Tobi
>
> [1] https://sourceforge.net/p/gambas/mailman/gambas-user/thread/BUG984:
> [hidden email]/
>
> --
> "There's an old saying: Don't change anything... ever!" -- Mr. Monk
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by gambas-user mailing list
Thanks Benoit,
I'm going to try and I'll tell you

Regards
Gianluigi

2017-06-21 15:32 GMT+02:00 Benoît Minisini <[hidden email]>:

> Le 21/06/2017 à 15:29, Benoît Minisini a écrit :
>
>> Le 21/06/2017 à 15:25, Gianluigi a écrit :
>>
>>> The libreries you have indicated are the last 5 of the command I
>>> suggested, which is not wrong.
>>> So I just have to let him to add libssl-dev, but I do not think his
>>> problem stems from this, right?
>>> Why he can not run Gambas and get these errors from the terminal?
>>> Settings.WriteWindow.393: #20: Bad argument
>>> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
>>> FMain.Form_Open.78 Project.Main.366
>>>
>>> Regards
>>> Gianluigi
>>>
>>>
>> I don't know. I'm working on Kubuntu 17.04, and I have no problem with
>> compiling Gambas, except the missing llvm 3.5.
>>
>>
> Can you try to recompile the very latest revision? I added some code that
> should avoid the specific crash you have.
>
> --
> Benoît Minisini
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

PICCORO McKAY Lenz
In reply to this post by Tobias Boege-2
2017-06-21 8:30 GMT-04:30 Tobias Boege <[hidden email]>:

> I have a very unpleasant memories [1] about the last time I changed the
> configure.ac of gb.openssl. Please make sure first that the openssl
> development packages are installed.
>
well without these "unpleasant" commits gambas not work in many embebed
devices .. that could be upgraded to use newer openssl due own vendors
mantain the 0.X releases.. and due very low space, its not good idead put
more libs either compiling by me if something fail.. due vendor will said
"its your faul"

in any case, i see again a last change that again make incompatible my
compilation.. i remenber that my path works with olders and newers and
works perfectly without problems or bugs.. i tested with the openssl-test
attached project in the bug reported (now closed)

i have my own GPS client connected to my manpowers for notifications.. more
cheap rather pay network connections and related, here in my countrie money
changes are no good...


>
> Regards,
> Tobi
>
> [1] https://sourceforge.net/p/gambas/mailman/gambas-user/thread/BUG984:
> [hidden email]/
>
> --
> "There's an old saying: Don't change anything... ever!" -- Mr. Monk
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by gambas-user mailing list
Hi Benoit,

our friend reports that now opens the tips window that works, but when he
closes the window Gambas does not start.
What other information do you need?
I asked him for an image, and if he finds Gambas out of the dash
Attached the new log files, it seems all right.

Regards
Gianluigi

2017-06-21 15:32 GMT+02:00 Benoît Minisini <[hidden email]>:

> Le 21/06/2017 à 15:29, Benoît Minisini a écrit :
>
>> Le 21/06/2017 à 15:25, Gianluigi a écrit :
>>
>>> The libreries you have indicated are the last 5 of the command I
>>> suggested, which is not wrong.
>>> So I just have to let him to add libssl-dev, but I do not think his
>>> problem stems from this, right?
>>> Why he can not run Gambas and get these errors from the terminal?
>>> Settings.WriteWindow.393: #20: Bad argument
>>> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
>>> FMain.Form_Open.78 Project.Main.366
>>>
>>> Regards
>>> Gianluigi
>>>
>>>
>> I don't know. I'm working on Kubuntu 17.04, and I have no problem with
>> compiling Gambas, except the missing llvm 3.5.
>>
>>
> Can you try to recompile the very latest revision? I added some code that
> should avoid the specific crash you have.
>
> --
> Benoît Minisini
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
In reply to this post by gambas-user mailing list
Missing attached here, sorry

Regards
Gianluigi


2017-06-21 15:32 GMT+02:00 Benoît Minisini <[hidden email]>:

> Le 21/06/2017 à 15:29, Benoît Minisini a écrit :
>
>> Le 21/06/2017 à 15:25, Gianluigi a écrit :
>>
>>> The libreries you have indicated are the last 5 of the command I
>>> suggested, which is not wrong.
>>> So I just have to let him to add libssl-dev, but I do not think his
>>> problem stems from this, right?
>>> Why he can not run Gambas and get these errors from the terminal?
>>> Settings.WriteWindow.393: #20: Bad argument
>>> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
>>> FMain.Form_Open.78 Project.Main.366
>>>
>>> Regards
>>> Gianluigi
>>>
>>>
>> I don't know. I'm working on Kubuntu 17.04, and I have no problem with
>> compiling Gambas, except the missing llvm 3.5.
>>
>>
> Can you try to recompile the very latest revision? I added some code that
> should avoid the specific crash you have.
>
> --
> Benoît Minisini
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user

LogFile.tar.gz (46K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors compiling on Ubuntu 17.04 zesty

Gianluigi
Hi Benoit,
problem solved.
He forgot to tell us he has Ubuntu with Unity and Gnome but uses only Gnome.
It was enough to run Gambas on Unity, which then started running on Gnome.

Regards
Gianluigi

2017-06-22 9:40 GMT+02:00 Gianluigi <[hidden email]>:

> Missing attached here, sorry
>
> Regards
> Gianluigi
>
>
> 2017-06-21 15:32 GMT+02:00 Benoît Minisini <[hidden email]>:
>
>> Le 21/06/2017 à 15:29, Benoît Minisini a écrit :
>>
>>> Le 21/06/2017 à 15:25, Gianluigi a écrit :
>>>
>>>> The libreries you have indicated are the last 5 of the command I
>>>> suggested, which is not wrong.
>>>> So I just have to let him to add libssl-dev, but I do not think his
>>>> problem stems from this, right?
>>>> Why he can not run Gambas and get these errors from the terminal?
>>>> Settings.WriteWindow.393: #20: Bad argument
>>>> Settings.WriteWindow.393 Settings.Write.439 FDebugInfo.UpdateView.848
>>>> FMain.Form_Open.78 Project.Main.366
>>>>
>>>> Regards
>>>> Gianluigi
>>>>
>>>>
>>> I don't know. I'm working on Kubuntu 17.04, and I have no problem with
>>> compiling Gambas, except the missing llvm 3.5.
>>>
>>>
>> Can you try to recompile the very latest revision? I added some code that
>> should avoid the specific crash you have.
>>
>> --
>> Benoît Minisini
>>
>
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
12
Loading...