I need help getting gambas running

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

I need help getting gambas running

John Fabiani-2
Hi,

I think I was able to install all the RPMS without issue but clicking
on /usr/bin/gambas2 does not start anything (just a bouncing icon) and from
the command I get "Cannot load class "Project":Version to old. Please
recompile."  I have checked the site along with the wiki site without getting
much from it.  Also I have googled the error message without any success.  If
I can't get anyone to help I guess I'll have to give up.  

John


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

Werner-4
John Fabiani wrote:

>Hi,
>
>I think I was able to install all the RPMS without issue but clicking
>on /usr/bin/gambas2 does not start anything (just a bouncing icon) and from
>the command I get "Cannot load class "Project":Version to old. Please
>recompile."  I have checked the site along with the wiki site without getting
>much from it.  Also I have googled the error message without any success.  If
>I can't get anyone to help I guess I'll have to give up.  
>
>John
>
>
>-------------------------------------------------------
>SF.Net email is Sponsored by the Better Software Conference & EXPO
>September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
>Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
>Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
>_______________________________________________
>Gambas-user mailing list
>[hidden email]
>https://lists.sourceforge.net/lists/listinfo/gambas-user
>
>.
>
>  
>
You need to tell us a little bit more.
What distribution / revision level are you using?
Which version of Gambas are you trying to install?

Regards,

Werner



-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

John Fabiani-2
thanks you are the only person to response.  SUSE 9.3, gambas2 1.9.17.  Also
is there a web site or doc available that explains how install process?
John

On Tuesday 06 September 2005 19:47, Werner wrote:

> John Fabiani wrote:
> >Hi,
> >
> >I think I was able to install all the RPMS without issue but clicking
> >on /usr/bin/gambas2 does not start anything (just a bouncing icon) and
> > from the command I get "Cannot load class "Project":Version to old.
> > Please recompile."  I have checked the site along with the wiki site
> > without getting much from it.  Also I have googled the error message
> > without any success.  If I can't get anyone to help I guess I'll have to
> > give up.
> >
> >John
> >
> >
> >-------------------------------------------------------
> >SF.Net email is Sponsored by the Better Software Conference & EXPO
> >September 19-22, 2005 * San Francisco, CA * Development Lifecycle
> > Practices Agile & Plan-Driven Development * Managing Projects & Teams *
> > Testing & QA Security * Process Improvement & Measurement *
> > http://www.sqe.com/bsce5sf
> > _______________________________________________
> >Gambas-user mailing list
> >[hidden email]
> >https://lists.sourceforge.net/lists/listinfo/gambas-user
> >
> >.
>
> You need to tell us a little bit more.
> What distribution / revision level are you using?
> Which version of Gambas are you trying to install?
>
> Regards,
>
> Werner
>
>
>
> -------------------------------------------------------
> SF.Net email is Sponsored by the Better Software Conference & EXPO
> September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
> Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
> Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

Werner-4
John Fabiani wrote:

>thanks you are the only person to response.  SUSE 9.3, gambas2 1.9.17.  Also
>is there a web site or doc available that explains how install process?
>John
>
>  
>
The latest stable version is 1.0.11. The development version is 1.9.20,
I think. The rpm's for suse 9.3 can be found here:
ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/SuSE_9.3/
Where did you get the rpm's from?

Gambas is also included in the suse distribution but I hear that one is
hopeless because suse built it all wrong.

Personally I use gambas 1.0.10 on suse 9.3 at the moment. It works quite
well. I just used Yast to install. It's a good idea to install
gambas-runtime as one of the first packages as some other packages
depend on it.

Werner

>On Tuesday 06 September 2005 19:47, Werner wrote:
>  
>
>>John Fabiani wrote:
>>    
>>
>>>Hi,
>>>
>>>I think I was able to install all the RPMS without issue but clicking
>>>on /usr/bin/gambas2 does not start anything (just a bouncing icon) and
>>>from the command I get "Cannot load class "Project":Version to old.
>>>Please recompile."  I have checked the site along with the wiki site
>>>without getting much from it.  Also I have googled the error message
>>>without any success.  If I can't get anyone to help I guess I'll have to
>>>give up.
>>>
>>>John
>>>
>>>
>>>-------------------------------------------------------
>>>SF.Net email is Sponsored by the Better Software Conference & EXPO
>>>September 19-22, 2005 * San Francisco, CA * Development Lifecycle
>>>Practices Agile & Plan-Driven Development * Managing Projects & Teams *
>>>Testing & QA Security * Process Improvement & Measurement *
>>>http://www.sqe.com/bsce5sf
>>>_______________________________________________
>>>Gambas-user mailing list
>>>[hidden email]
>>>https://lists.sourceforge.net/lists/listinfo/gambas-user
>>>
>>>.
>>>      
>>>
>>You need to tell us a little bit more.
>>What distribution / revision level are you using?
>>Which version of Gambas are you trying to install?
>>
>>Regards,
>>
>>Werner
>>
>>
>>
>>-------------------------------------------------------
>>SF.Net email is Sponsored by the Better Software Conference & EXPO
>>September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
>>Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
>>Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
>>_______________________________________________
>>Gambas-user mailing list
>>[hidden email]
>>https://lists.sourceforge.net/lists/listinfo/gambas-user
>>    
>>
>
>
>-------------------------------------------------------
>SF.Net email is Sponsored by the Better Software Conference & EXPO
>September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
>Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
>Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
>_______________________________________________
>Gambas-user mailing list
>[hidden email]
>https://lists.sourceforge.net/lists/listinfo/gambas-user
>
>.
>
>  
>



-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

John Fabiani-2
I could not get gambas1 working using the DVD so I decided to install the
gambas2.  The sourceforge has a link to the SUSE 9.3 RPM's.  So I just
installed all the Gambas2 RPM's for 1.9.17.  But the link you provided has
the RPM's for 1.9.20.  The only question I have - after I install all the
Gambas2 RPM's is there anything else required.  I have development packages
for QT,Postgres, and gcc 3.3.5 installed.  

John

On Tuesday 06 September 2005 22:58, Werner wrote:

> John Fabiani wrote:
> >thanks you are the only person to response.  SUSE 9.3, gambas2 1.9.17.
> > Also is there a web site or doc available that explains how install
> > process? John
>
> The latest stable version is 1.0.11. The development version is 1.9.20,
> I think. The rpm's for suse 9.3 can be found here:
> ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/SuSE_9.3/
> Where did you get the rpm's from?
>
> Gambas is also included in the suse distribution but I hear that one is
> hopeless because suse built it all wrong.
>
> Personally I use gambas 1.0.10 on suse 9.3 at the moment. It works quite
> well. I just used Yast to install. It's a good idea to install
> gambas-runtime as one of the first packages as some other packages
> depend on it.
>
> Werner
>
> >On Tuesday 06 September 2005 19:47, Werner wrote:
> >>John Fabiani wrote:
> >>>Hi,
> >>>
> >>>I think I was able to install all the RPMS without issue but clicking
> >>>on /usr/bin/gambas2 does not start anything (just a bouncing icon) and
> >>>from the command I get "Cannot load class "Project":Version to old.
> >>>Please recompile."  I have checked the site along with the wiki site
> >>>without getting much from it.  Also I have googled the error message
> >>>without any success.  If I can't get anyone to help I guess I'll have to
> >>>give up.
> >>>
> >>>John
> >>>
> >>>
> >>>-------------------------------------------------------
> >>>SF.Net email is Sponsored by the Better Software Conference & EXPO
> >>>September 19-22, 2005 * San Francisco, CA * Development Lifecycle
> >>>Practices Agile & Plan-Driven Development * Managing Projects & Teams *
> >>>Testing & QA Security * Process Improvement & Measurement *
> >>>http://www.sqe.com/bsce5sf
> >>>_______________________________________________
> >>>Gambas-user mailing list
> >>>[hidden email]
> >>>https://lists.sourceforge.net/lists/listinfo/gambas-user
> >>>
> >>>.
> >>
> >>You need to tell us a little bit more.
> >>What distribution / revision level are you using?
> >>Which version of Gambas are you trying to install?
> >>
> >>Regards,
> >>
> >>Werner
> >>
> >>
> >>
> >>-------------------------------------------------------
> >>SF.Net email is Sponsored by the Better Software Conference & EXPO
> >>September 19-22, 2005 * San Francisco, CA * Development Lifecycle
> >> Practices Agile & Plan-Driven Development * Managing Projects & Teams *
> >> Testing & QA Security * Process Improvement & Measurement *
> >> http://www.sqe.com/bsce5sf
> >> _______________________________________________
> >>Gambas-user mailing list
> >>[hidden email]
> >>https://lists.sourceforge.net/lists/listinfo/gambas-user
> >
> >-------------------------------------------------------
> >SF.Net email is Sponsored by the Better Software Conference & EXPO
> >September 19-22, 2005 * San Francisco, CA * Development Lifecycle
> > Practices Agile & Plan-Driven Development * Managing Projects & Teams *
> > Testing & QA Security * Process Improvement & Measurement *
> > http://www.sqe.com/bsce5sf
> > _______________________________________________
> >Gambas-user mailing list
> >[hidden email]
> >https://lists.sourceforge.net/lists/listinfo/gambas-user
> >
> >.
>
> -------------------------------------------------------
> SF.Net email is Sponsored by the Better Software Conference & EXPO
> September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
> Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
> Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

Werner-4
It depends on what you want to do, contributing to the development of
Gambas or just use it?

Version 1.9.xx is a hard hat area so if you are new it might be a good
idea to start with a stable version. I assume you are new.

You mention a DVD. Presumably that would be the SuSE DVD. For the second
time, the Gambas rpm in the SuSE distribution is NO GOOD. An explanation
of the reason why can be found in the archive of this mailing list.

I suggest to use the 1.0.11 which you can find at the link mentioned
below and try this stable version first.

Werner

John Fabiani wrote:

>I could not get gambas1 working using the DVD so I decided to install the
>gambas2.  The sourceforge has a link to the SUSE 9.3 RPM's.  So I just
>installed all the Gambas2 RPM's for 1.9.17.  But the link you provided has
>the RPM's for 1.9.20.  The only question I have - after I install all the
>Gambas2 RPM's is there anything else required.  I have development packages
>for QT,Postgres, and gcc 3.3.5 installed.  
>
>John
>
>On Tuesday 06 September 2005 22:58, Werner wrote:
>  
>
>>John Fabiani wrote:
>>    
>>
>>>thanks you are the only person to response.  SUSE 9.3, gambas2 1.9.17.
>>>Also is there a web site or doc available that explains how install
>>>process? John
>>>      
>>>
>>The latest stable version is 1.0.11. The development version is 1.9.20,
>>I think. The rpm's for suse 9.3 can be found here:
>>ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/SuSE_9.3/
>>Where did you get the rpm's from?
>>
>>Gambas is also included in the suse distribution but I hear that one is
>>hopeless because suse built it all wrong.
>>
>>Personally I use gambas 1.0.10 on suse 9.3 at the moment. It works quite
>>well. I just used Yast to install. It's a good idea to install
>>gambas-runtime as one of the first packages as some other packages
>>depend on it.
>>
>>Werner
>>
>>    
>>
>>>On Tuesday 06 September 2005 19:47, Werner wrote:
>>>      
>>>
>>>>John Fabiani wrote:
>>>>        
>>>>
>>>>>Hi,
>>>>>
>>>>>I think I was able to install all the RPMS without issue but clicking
>>>>>on /usr/bin/gambas2 does not start anything (just a bouncing icon) and
>>>>>          
>>>>>
>>>>>from the command I get "Cannot load class "Project":Version to old.
>>>>        
>>>>
>>>>>Please recompile."  I have checked the site along with the wiki site
>>>>>without getting much from it.  Also I have googled the error message
>>>>>without any success.  If I can't get anyone to help I guess I'll have to
>>>>>give up.
>>>>>
>>>>>John
>>>>>
>>>>>
>>>>>.
>>>>>          
>>>>>
>>>>You need to tell us a little bit more.
>>>>What distribution / revision level are you using?
>>>>Which version of Gambas are you trying to install?
>>>>
>>>>Regards,
>>>>
>>>>Werner
>>>>
>>>>
>>>>
>>>>        
>>>>



-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

John Fabiani-2
Well I download all of the gambas2 stuff.  Could we try using that first -
since I downloaded it?  Should I make an effort to remove the old version
first?

John
On Wednesday 07 September 2005 08:57, Werner wrote:

> It depends on what you want to do, contributing to the development of
> Gambas or just use it?
>
> Version 1.9.xx is a hard hat area so if you are new it might be a good
> idea to start with a stable version. I assume you are new.
>
> You mention a DVD. Presumably that would be the SuSE DVD. For the second
> time, the Gambas rpm in the SuSE distribution is NO GOOD. An explanation
> of the reason why can be found in the archive of this mailing list.
>
> I suggest to use the 1.0.11 which you can find at the link mentioned
> below and try this stable version first.
>
> Werner
>
> John Fabiani wrote:
> >I could not get gambas1 working using the DVD so I decided to install the
> >gambas2.  The sourceforge has a link to the SUSE 9.3 RPM's.  So I just
> >installed all the Gambas2 RPM's for 1.9.17.  But the link you provided has
> >the RPM's for 1.9.20.  The only question I have - after I install all the
> >Gambas2 RPM's is there anything else required.  I have development
> > packages for QT,Postgres, and gcc 3.3.5 installed.
> >
> >John
> >
> >On Tuesday 06 September 2005 22:58, Werner wrote:
> >>John Fabiani wrote:
> >>>thanks you are the only person to response.  SUSE 9.3, gambas2 1.9.17.
> >>>Also is there a web site or doc available that explains how install
> >>>process? John
> >>
> >>The latest stable version is 1.0.11. The development version is 1.9.20,
> >>I think. The rpm's for suse 9.3 can be found here:
> >>ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/SuSE_9.3/
> >>Where did you get the rpm's from?
> >>
> >>Gambas is also included in the suse distribution but I hear that one is
> >>hopeless because suse built it all wrong.
> >>
> >>Personally I use gambas 1.0.10 on suse 9.3 at the moment. It works quite
> >>well. I just used Yast to install. It's a good idea to install
> >>gambas-runtime as one of the first packages as some other packages
> >>depend on it.
> >>
> >>Werner
> >>
> >>>On Tuesday 06 September 2005 19:47, Werner wrote:
> >>>>John Fabiani wrote:
> >>>>>Hi,
> >>>>>
> >>>>>I think I was able to install all the RPMS without issue but clicking
> >>>>>on /usr/bin/gambas2 does not start anything (just a bouncing icon) and
> >>>>>
> >>>>>
> >>>>>from the command I get "Cannot load class "Project":Version to old.
> >>>>>
> >>>>>
> >>>>>Please recompile."  I have checked the site along with the wiki site
> >>>>>without getting much from it.  Also I have googled the error message
> >>>>>without any success.  If I can't get anyone to help I guess I'll have
> >>>>> to give up.
> >>>>>
> >>>>>John
> >>>>>
> >>>>>
> >>>>>.
> >>>>
> >>>>You need to tell us a little bit more.
> >>>>What distribution / revision level are you using?
> >>>>Which version of Gambas are you trying to install?
> >>>>
> >>>>Regards,
> >>>>
> >>>>Werner
>
> -------------------------------------------------------
> SF.Net email is Sponsored by the Better Software Conference & EXPO
> September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
> Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
> Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

Rob Kudla
On Wed September 7 2005 12:10, John Fabiani wrote:
> Well I download all of the gambas2 stuff.  Could we try using that
> first - since I downloaded it?  Should I make an effort to remove
> the old version first?

Yes, if you have a version installed from RPM, you should definitely
remove that prior to doing "make install" on a version you've
compiled from source.

Rob



-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: I need help getting gambas running

John Fabiani-2
Ok I first removed all YAST entries of gambas.  Then I installed all of the
gambas2 and get the same error (project needs to be recompiled).  Anyway now
I will try the gambas1.
John
On Wednesday 07 September 2005 09:20, Rob Kudla wrote:

> On Wed September 7 2005 12:10, John Fabiani wrote:
> > Well I download all of the gambas2 stuff.  Could we try using that
> > first - since I downloaded it?  Should I make an effort to remove
> > the old version first?
>
> Yes, if you have a version installed from RPM, you should definitely
> remove that prior to doing "make install" on a version you've
> compiled from source.
>
> Rob
>
>
>
> -------------------------------------------------------
> SF.Net email is Sponsored by the Better Software Conference & EXPO
> September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
> Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
> Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user