Media playback

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Media playback

Charlie
Can anybody tell me what dependencies are needed to play a video? The program VerySimpleVideoPlayer (see the Gambas Farm) works perfectly in Ubuntu & Mint but not in ToOpPy Linux which is based on Puppy Linux.

Any help appreciated.

Check out www.gambas.one

Reply | Threaded
Open this post in threaded view
|

Re: Media playback

Charlie
Can nobody help me?

Check out www.gambas.one

Reply | Threaded
Open this post in threaded view
|

Re: Media playback

Fabien Bodard-4
2017-03-02 16:01 GMT+01:00 Charlie <[hidden email]>:
> Can nobody help me?

it's difficult without the system... but normally you need all the
gstream 1.0 stuff

>
>
>
>
> -----
> Check out www.gambas.one
> --
> View this message in context: http://gambas.8142.n7.nabble.com/Media-playback-tp58542p58563.html
> Sent from the gambas-user mailing list archive at Nabble.com.
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Gambas-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gambas-user



--
Fabien Bodard

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: Media playback

gbwilly
In reply to this post by Charlie
On 2017-02-23 18:49, Charlie wrote:
> Can anybody tell me what dependencies are needed to play a video? The
> program
> *VerySimpleVideoPlayer* (see the Gambas Farm) works perfectly in Ubuntu
> &
> Mint but not in ToOpPy Linux which is based on Puppy Linux.
> Any help appreciated.
>

 From the Installation and compilation instructions of Gambas wiki
(http://gambaswiki.org/wiki/install):

gstreamer-0.10 >= 0.10.31, gstreamer-interfaces-0.10 >= 0.10.31 for
Gambas <= 3.4
gstreamer-1.0, gstreamer-video-1.0 for Gambas >= 3.5

How these packages are called in To0pPy Linux I don't know.

gbWilly

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: Media playback

Charlie
Thanks Fabien and bgWilly,

I was looking at this on behalf of someone else. I have discovered that the ToOpPy Linux 2.2 (the latest) is based on Ubuntu 12.04 which came with Gambas2! None of the 'gstreamer-1' software, needed for Gambas 3.9.x, is available from the ToOpPy repositories.

Check out www.gambas.one

Reply | Threaded
Open this post in threaded view
|

Re: Media playback

gbwilly
On 2017-03-05 15:53, Charlie wrote:
> Thanks Fabien and bgWilly,
> I was looking at this on behalf of someone else. I have discovered that
> the
> ToOpPy Linux 2.2 (the latest) is based on Ubuntu 12.04 which came with
> Gambas2! None of the 'gstreamer-1' software, needed for Gambas 3.9.x,
> is
> available from the ToOpPy repositories.

Ubuntu 12.04 has a backport repository holding the proper gstreamer
version.
If someone would use those as a base to package gstreamer for To0pPy
your problem would be solved.

gbWilly


------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user
Reply | Threaded
Open this post in threaded view
|

Re: Media playback

gbwilly
On 2017-03-07 20:10, [hidden email] wrote:

> On 2017-03-05 15:53, Charlie wrote:
>> Thanks Fabien and bgWilly,
>> I was looking at this on behalf of someone else. I have discovered
>> that
>> the
>> ToOpPy Linux 2.2 (the latest) is based on Ubuntu 12.04 which came with
>> Gambas2! None of the 'gstreamer-1' software, needed for Gambas 3.9.x,
>> is
>> available from the ToOpPy repositories.
>
> Ubuntu 12.04 has a backport repository holding the proper gstreamer
> version.
> If someone would use those as a base to package gstreamer for To0pPy
> your problem would be solved.
>
> gbWilly


Sorry Charlie,

I'm wrong. It's Ubuntu 14.04 or higher for gstreamer 1.0
So, no backports for 12.04

gbWilly


------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Gambas-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user