New gb.qt5 component

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

New gb.qt5 component

Sebastian Kulesz
Hi Benoît, I saw the new gb.qt5 component and added it to the Daily PPA so you can get early feedback. 

In the last commit you forced the minimum version to 5.4 because the gb.qt5.opengl component. I wanted to know if the rest of the QT5 components are compatible with 5.3, or even 5.2, so that I can backport them to previous Ubuntu releases.

Thanks!

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel
Reply | Threaded
Open this post in threaded view
|

Re: New gb.qt5 component

Benoît Minisini
Le 11/05/2015 05:00, Sebastian Kulesz a écrit :

> Hi Benoît, I saw the new gb.qt5 component and added it to the Daily PPA
> so you can get early feedback.
>
> In the last commit you forced the minimum version to 5.4 because the
> gb.qt5.opengl component. I wanted to know if the rest of the QT5
> components are compatible with 5.3, or even 5.2, so that I can backport
> them to previous Ubuntu releases.
>
> Thanks!
>

The new QT5 OpenGL widget requires QT 5.4. The old one from QT4 is still
there, but the documentation says that we should not use it.

I will try to see if I can use it anyway so that QT <= 5.3 can be used,
and I will tell you.

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel
Reply | Threaded
Open this post in threaded view
|

Re: New gb.qt5 component

Benoît Minisini
Le 11/05/2015 13:45, Benoît Minisini a écrit :

> Le 11/05/2015 05:00, Sebastian Kulesz a écrit :
>> Hi Benoît, I saw the new gb.qt5 component and added it to the Daily PPA
>> so you can get early feedback.
>>
>> In the last commit you forced the minimum version to 5.4 because the
>> gb.qt5.opengl component. I wanted to know if the rest of the QT5
>> components are compatible with 5.3, or even 5.2, so that I can backport
>> them to previous Ubuntu releases.
>>
>> Thanks!
>>
>
> The new QT5 OpenGL widget requires QT 5.4. The old one from QT4 is still
> there, but the documentation says that we should not use it.
>
> I will try to see if I can use it anyway so that QT <= 5.3 can be used,
> and I will tell you.
>
> Regards,
>

It's done in revision #7079: the gb.qt5.opengl now can use Qt 5.3.

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel
Reply | Threaded
Open this post in threaded view
|

Re: New gb.qt5 component

Benoît Minisini
Le 11/05/2015 23:36, Benoît Minisini a écrit :

> Le 11/05/2015 13:45, Benoît Minisini a écrit :
>> Le 11/05/2015 05:00, Sebastian Kulesz a écrit :
>>> Hi Benoît, I saw the new gb.qt5 component and added it to the Daily PPA
>>> so you can get early feedback.
>>>
>>> In the last commit you forced the minimum version to 5.4 because the
>>> gb.qt5.opengl component. I wanted to know if the rest of the QT5
>>> components are compatible with 5.3, or even 5.2, so that I can backport
>>> them to previous Ubuntu releases.
>>>
>>> Thanks!
>>>
>>
>> The new QT5 OpenGL widget requires QT 5.4. The old one from QT4 is still
>> there, but the documentation says that we should not use it.
>>
>> I will try to see if I can use it anyway so that QT <= 5.3 can be used,
>> and I will tell you.
>>
>> Regards,
>>
>
> It's done in revision #7079: the gb.qt5.opengl now can use Qt 5.3.
>
> Regards,
>

Another not related point: to compile gb.jit with Kubuntu 15.10, you
have to install llvm 3.5 and configure the component that way:

LLVM_CONFIG=llvm-config-3.5 ./configure -C

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel
Reply | Threaded
Open this post in threaded view
|

Re: New gb.qt5 component

Sebastian Kulesz
It seems like the IDE now requires gb.qt5 since commit 7092. Ubuntu precise lacks QT5 packages, and would be left out without support. Is this only a test, or will the IDE move to gb.qt5 permanently?

On Mon, May 11, 2015 at 6:49 PM, Benoît Minisini <[hidden email]> wrote:
Le 11/05/2015 23:36, Benoît Minisini a écrit :
> Le 11/05/2015 13:45, Benoît Minisini a écrit :
>> Le 11/05/2015 05:00, Sebastian Kulesz a écrit :
>>> Hi Benoît, I saw the new gb.qt5 component and added it to the Daily PPA
>>> so you can get early feedback.
>>>
>>> In the last commit you forced the minimum version to 5.4 because the
>>> gb.qt5.opengl component. I wanted to know if the rest of the QT5
>>> components are compatible with 5.3, or even 5.2, so that I can backport
>>> them to previous Ubuntu releases.
>>>
>>> Thanks!
>>>
>>
>> The new QT5 OpenGL widget requires QT 5.4. The old one from QT4 is still
>> there, but the documentation says that we should not use it.
>>
>> I will try to see if I can use it anyway so that QT <= 5.3 can be used,
>> and I will tell you.
>>
>> Regards,
>>
>
> It's done in revision #7079: the gb.qt5.opengl now can use Qt 5.3.
>
> Regards,
>

Another not related point: to compile gb.jit with Kubuntu 15.10, you
have to install llvm 3.5 and configure the component that way:

LLVM_CONFIG=llvm-config-3.5 ./configure -C

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel


------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel
Reply | Threaded
Open this post in threaded view
|

Re: New gb.qt5 component

Benoît Minisini
Le 26/05/2015 07:50, Sebastian Kulesz a écrit :
> It seems like the IDE now requires gb.qt5 since commit 7092. Ubuntu
> precise lacks QT5 packages, and would be left out without support. Is
> this only a test, or will the IDE move to gb.qt5 permanently?
>

At the moment it is a test, but now gb.qt5 works correctly enough for
the IDE.

I'm currently thinking of making two special QT components (a bit like
gb.gui) that would load gb.qt5 if present, and gb.qt4 otherwise. That
way, I won't have to make two versions of the IDE project, one for the
old Linux with gb.qt4, and one for the new ones with gb.qt5.

Regards,

--
Benoît Minisini

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gambas-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-devel