compilation Gambas 3.4.1 sous Debian Squeeze

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

compilation Gambas 3.4.1 sous Debian Squeeze

Alarc'h
Bonjour,

Pour pouvoir migrer de Debian Squeeze à Wheezy je dois porter quelques
applications de Gambas 2 à Gambas 3, car il sera sans doute difficile
de compiler Gambase 2 sur Wheezy qui n'a plus de paquets qt3.

Je tente donc de compiler Gambas 3.4.1 sur Squeeze.

J'ai trouvé cette liste de dépendances à installer :

build-essential autoconf libbz2-dev libmysqlclient-dev unixodbc-dev
libpq-dev libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev
libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev
libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev
librsvg2-dev libpoppler-dev libpoppler-glib-dev libxtst-dev libffi-dev
libqt4-dev libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev
libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgsl0-dev
libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libcairo2-dev
libgsl0-dev

Après une première compilation j'ai vu qu'il fallait rajouter libgmime
qui n'est disponible sur Squeeze qu'en version 2.4 : libgmime-2.4-dev

Premier problème le paquet libgdk-pixbuf2.0-dev n'existe pas dans les
dépôts Debian (d'après ce que j'ai compris c'est un paquet Ubuntu). En
cherchant dans les listes de paquet je trouve seulement :

libgdk-pixbuf2-ruby - Gdk-Pixbuf 2 bindings for the Ruby language
libgdk-pixbuf2-ruby1.8 - Gdk-Pixbuf 2 bindings for the Ruby language
libgdk-pixbuf2-ruby1.8-dbg - Gdk-Pixbuf 2 bindings for the Ruby
language
libgdkcutter-pixbuf-dev - Cutter Gdk-pixbuf support (Development files)
libgdkcutter-pixbuf0 - Cutter Gdk-pixbuf support (Shared library)

Quelqu'un peut-il me dire ce qu'est censé installer ce paquet et quel
paquet Debian, si il existe, installer à la place ?

j'ai réussi à compiler Gambas tout de même mais il manque des
composants. Quand je regarde dans un projet la liste des composants
disponibles je vois en grisé (non installés) les modules :

gb.chart
gb.map
gb.mysql
gb.ncurses
gb.option

Voici les informations système que j'ai trouvées dans l'IDE de gambas :

[System]
OperatingSystem=Linux
Kernel=2.6.32-5-686
Architecture=x86
Distribution=debian 6.0.7
Desktop=?
Theme=QPlastique
Language=fr_FR.UTF-8
Memory=1002M

[Libraries]
GStreamer=libgstreamer-0.10.so.0.26.0
GTK+=libgtk-x11-2.0.so.0.2000.1
Poppler=libpoppler.so.5.0.0
Qt4=libQtCore.so.4.6.3
SDL=libSDL-1.2.so.0.11.3

Le Desktop que j'utilise est Trinity (c'est à dire KDE 3.5 adapté pour
qt4 qui est un fork réalisé par l'ancien mainteneur de kubuntu) car
j'ai besoin de quanta+ qui n'existe plus sous KDE4 et que je n'aime
pas trop KDE4. Quelques unes de mes misères pourraient-elles venir de
là ?

Lors de la compilation par mesure de précaution j'ai créé un fichier
qui contient les sortes de config, make et make install comme indiqué
dans la doc Gambas. Il est trop gros pour être envoyé ici mais je
peux le communiquer si besoin. Ce que j'y ai vu qui me semble
intéressant est ceci :

grep "^||" GB341config.txt
||
|| Unable to find file: libintl.so
|| This library may be located inside the system C library, so you can
ignore that warning...
|| Unable to find file: libiconv.so
|| This library may be located inside the system C library, so you can
ignore that warning...
||
||
|| Unable to met pkg-config requirement: gmime-2.6
|| But gmime 2.4 has been detected!
||
||
|| Unable to met pkg-config requirement: > 1.2.8
|| Unable to met pkg-config requirement: SDL_ttf
||
||
|| Unable to met pkg-config requirement: gstreamer-0.10 >= 0.10.31
|| gb.media is disabled
||
||
|| gb.jit is disabled
||
||
|| THESE COMPONENTS ARE DISABLED:
|| - gb.jit
|| - gb.media
||

Quelqu'un sait-il quelles dépendances me manquent (notamment mysql qui
m'intrigue car j'ai les paquets mysql). Pour gstreamer la version de
squeeze est 0.10.30 donc pas supérieure ou égale à 0.10.31. Il me
semble que ce n'est que pour la gestion du son qui dans mes
applications ne me sert pas. Mais j'aimerais tout de même parvenir à
compiler un gambas complet.  

Est-ce qu'une version plus anciennne de Gambase 3 aurait des exigences
moindres sur les dépendances et pourrait compiler complètement ?

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr
Reply | Threaded
Open this post in threaded view
|

Re: compilation Gambas 3.4.1 sous Debian Squeeze

jibi
bonjour

pour gambas3
si cela peut t'aider : http://www.gambasforge.org/sujet-4312-gbjit-et-gbmedia-page-1.html#m15

et pour gambas2 :
http://ftp.debian.org/debian/pool/main/g/gambas2/
et ici ya pas mal de paquet n'étant plus dans debian
http://packages.trisquel.info/fr/taranis-updates/i386/libpoppler5/download
pour libqt3
http://packages.debian.org/fr/squeeze/libqt3-mt-dev
http://blog.elisya.org/blog/2013/06/04/installer-pdfedit-wheezy/

voilà les liens que je peux te proposer
jibi
Linux bureau Kde 4.8.4 / noyau 3.2.0-4-686-pae #1 / SMP Debian 3.2.46-1 i686 GNU/Linux bureau KDE
Reply | Threaded
Open this post in threaded view
|

Re: compilation Gambas 3.4.1 sous Debian Squeeze

Alarc'h
Le Fri, 28 Jun 2013 00:36:32 -0700 (PDT),
jibi <[hidden email]> a écrit :

[...]

Merci

je vais regarder ça de près. Je reviendrai si j'ai des remarques
pertinentes qui pourraient être utiles.

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gambas-user-fr mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gambas-user-fr